1
0
Fork 0
nix-overlay/packages/vuetorrent.nix

32 lines
766 B
Nix

{ pkgs, lib }:
pkgs.stdenv.mkDerivation rec {
pname = "vuetorrent";
version = "2.12.0";
src = pkgs.fetchurl {
url = "https://github.com/WDaan/VueTorrent/releases/download/v${version}/vuetorrent.zip";
sha256 = "sha256-jgzWvJpQYTyteFLcq1rdA0tzFnw9K1iA71CllisL+D0=";
};
buildInputs = with pkgs; [ unzip ];
unpackPhase = ''
unzip $src
'';
dontStrip = true;
installPhase = ''
mkdir -p $out/share/
cp -r vuetorrent/public/ $out/share/
'';
meta = with lib; {
description = "The sleekest looking WEBUI for qBittorrent made with Vuejs! ";
homepage = "https://github.com/WDaan/VueTorrent";
license = [ licenses.gpl3Only ];
platforms = [ "x86_64-darwin" "aarch64-darwin" "aarch64-linux" "x86_64-linux" ];
};
}